Symptoms
Stuck sessions are occurring during testing, and it can be seen that this is related to User Account Control pop-ups.
Cause
Stuck sessions will be caused by User Account Control settings being enabled on the targets. This will prevent successful Login VSI test runs, especially when default Login VSI workloads are being utilized. The Login VSI virtual user running the workload won't be able to get past UAC pop-ups if they occur.
Resolution
Disable the User Account Control settings affecting the Login VSI target test users.
This is located in group policy settings at: Security Settings\Local Policies\Security Options
The policy settings that are recommended to should be set are:
Policy | Setting |
---|---|
User Account Control: Admin Approval Mode for the Built-in Administrator account | Disabled |
User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode | Elevate without prompting |
User Account Control: Detect application installations and prompt for elevation | Disabled |
User Account Control: Only elevate executables that are signed and validated | Disabled |
User Account Control: Run all administrators in Admin Approval Mode | Disabled |
User Account Control: Switch to the secure desktop when prompting for elevation | Disabled |
Note: the Login VSI AD setup will configure these settings by default
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