Symptoms
Sometimes the following error occurs, during the Login VSI workload.
Internet Explorer has stopped working
Cause
This is actually a known issue with Microsoft Internet Explorer 11. It crashes and because of that the LoginVSI engine expects it to get a response from those machines. Because it is stuck with that particular error, it cannot progress any further, and because of that, it will not take screenshots. Microsoft has not fixed the bug yet, but we have found workarounds in LoginVSI. Here is what you will want to do.
Resolution
Option 1:
- Please download http://upload.loginvsi.com/Support/feb15/VSIDebugIE.zip
- Replace the existing version of VSI.exe.
- Run a test with both engine and workload logging enabled.
- Send us the raw data if you hit the issue.
Option 2:
- The workaround.
- Open the registry editor and go to the section below and locate the TabProcGrowth key:
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main - If the key does not exist, create a new DWORD (32-bit) Value or String Value and name it as
TabProcGrowth
. - Set the value of the TabProcGrowth key to some high number like 40. This will instruct IE to open the first 40 tabs in a new iexplore.exe process.
Please note: You need to restart the machine for these settings to take effect.
Properties
Applies to:
Internet Explorer 11
Resources
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