Symptom
When logging into a target user which runs the target Login VSI logon script automatically, this can sometimes be seen. The pop-up looks like an error has likely occurred, but ordinarily the case is that a test is not in progress; basically, a status message. It will look like similar to this:
"Login VSI Fatal Error
Unable to proceed. Found less or more than one *.activetest file in the vsishare at path: {LoginVSI_serverHost_path}
Login VSI will stop executing."
Cause
After the logon script runs on the target it will hand off the Login VSI operation to the target engine via running the vsi.exe in the logon mode (using the "/logon" command-line switch). One of the tasks the logon mode will perform is seeing if there is a test in progress by checking how many *.isactivetest files are in the root of the Login VSI share. This *.isactivetest file is present when a test is in progress, and there should only be one. When there is no *.isactivetest file at all, this pop-up will occur. (Note, it's unlikely there will ever be multiple *.isactivetest files in the root of the share.)
Resolution
The scenarios that commonly cause the pop-up
- Logging into a system manually with a test user, which will automatically run the logon script, yet there isn't a test in progress
- If there is supposed to be a test in progress and this message is coming up unexpectedly, the "steady state" timing configuration (logoff countdown timer) might be too short to accommodate all the test users to become active, especially those launching at the end of the ramp-up (launch window) phase. This is configurable here, and is by default 2 minutes -- try making this longer:
Properties
Applies to
Login VSI 4.x
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