Symptom
You have a legal notice in place for your end users that appears during the launcher's connection to the desktop resource. The launcher cannot complete the connection to the desktop resource as the session sits and waits for the notice to be acknowledged.
Cause
The legal notice needs to be acknowledged before it will allow the connection to be made. This is not something that a Login PI 3.x or Login VSI 4.x launcher handles by default.
Resolution
Add the Legal Notice Dismissal tool to the launcher startup script.
Download the tool at the bottom of this page, unzip it and copy it to your Login VSI VSIshare folder -
Go to your domain controller’s netlogon folder. (Eg., \\DomainController.com\netlogon)
In there you should find a V4-VSI_Launcher batch file. Simply open the batch file to edit it, and add a line before the call to agent.exe
The new line should read (roughly):
\\YourVSIServer\YourVSIShareFolder\loginvsiwindowcapture.exe “WindowTitleName” 5
Note - Please replace
- "YourVSIServer" with your Login VSI management server hostname
- "YourVSIShareFolder" with the shared folder name
- "WindowTitleName" is the part of the Window Title name you would like to match. This can include all or part of the window title string. Just make sure you are matching the part of the window title that is the same every time. Wildcards are not accepted. If you want to match part of the string, just put that part in there. For example, if the Window Title is "4311-1234431-123423 - Citrix Receiver", then you can just add "Citrix Receiver" as the WindowTitleName.
- "5" is the amount of time to wait in seconds after the connection window appears, before attempting to dismiss the legal banner (5 is the default).
Requirements
Requires .NET 3.5
Properties
Not specific to any versions of VSI or PI, but technically should work with both.
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