Symptom
The Launcher Agent (agent.exe) can produce a message, which reads:
("The test with GUID: has already been executed. Waiting for a new test to start. VSI will continue in {seconds}s")
Cause
This is caused by the "Run agent in loop" setting being toggled on. This setting is located at: Login VSI Management Console -> Options -> Run agent in loop
In this case, during an active test, once a Launcher Agent has run its last connection command-line it will restart the agent.exe.
It will check what the in-progress test's GUID is by reading the value in the *.isactivetest file in the root of the Login VSIshare. (Note: the *.isactivetest file exists when a test is in progress.)
If the GUID value exists in the *.isactivetest file, the agent.exe will compare this against what's in the registry path "HKCU\Software\Login VSI\VSI Launcher\Runs\{GUID}".
If there's a match, the message box will be produced regarding the test GUID already being in progress.
Solution
This message is just status-related and informational, although it looks potentially like an error. It can be safely ignored and will go away by itself after 10 seconds. The agent.exe will silently continue polling the share, in the configured intervals, to check if a new test is being prepared.
See also:
- https://www.loginvsi.com/documentation/index.php?title=Login_VSI_Launcher
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